Buggfix Plus
Aktuellt datum och tid: 18.44 2019-12-10

Alla tidsangivelser är UTC + 1 timme




Svara på tråd  [ 55 inlägg ]  Gå till sida Föregående  1, 2, 3, 4
Författare Meddelande
 Inläggsrubrik: Re: Ljud-minnebygge
InläggPostat: 22.47 2019-10-31 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.41 2012-12-13
Inlägg: 10854
Ort: Göteborg
Jag har lite grann kommit på problemet.

Symptomen är följande:
1) Låg referensspänning (~30mV) över motståndsstegen fungerar inte
2) Hög referensspänning (~1V) över motståndsstegen fungerar

Sättet det inte fungerar på pekar på offset-problem och jag har försökt justera offset men TROLIGTVIS inte fattat att ALLA 10 komparatorer inuti kretsen har olika offset med maxvärde runt 10mV.

Så om jag nu satt 30mV för LED10 (varvid LED 1 hamnar på 1mV) och försöker detektera säg 10mV när offset är 10mV så är det resonemanget inte helt obegripligt även om jag inte begriper det i detalj.

En sak är dock klar och det är att om man skall korrekt lyckas förstärka nåt så måste offset var mindre än spänningen man försöker förstärka, bra mycket mindre tom.

Så nånstans här har jag problemet.

Det finns dock en rätt galant lösning till problemet enligt databladet (som för övrigt inte rekommenderar min lösning, ser jag nu, samtidigt som min lösning bara var en kopia av vad som stod i databladet), man har samma HÖGA omvandlingsområde (spänningen på resistansstegen, Vih) på båda kretsarna och inför en förstärkare som förstärker 31,6ggr (1V-30dB) vars utsignal kopplas till första kretsen som alltså har SAMMA referensspänning som den översta kretsen som uppenbarligen också klaras vid mina tester dvs 1V som range funkar utmärkt men 31,6mV som range funkar inte.

Fast det är inte så konstigt att jag stött på problem när jag inbillat mig att systemet skall kunna hantera signalnivåer som är mindre än en MM-pickups.

Så i morgon kommer jag vira dit en OP.

Eftersom det handlar om enkel matningsspänning blir det en LM324 vars utgång som minst är mindre än 20mV som är UNDER 31,6mV som är första kretsens LED1 (1V-30dB).

Behöver alltså bara en OP, nån som vet vad en singel 324 heter?

MVH/Roger


Upp
 Profil  
 
 Inläggsrubrik: Re: Ljud-minnebygge
InläggPostat: 11.48 2019-11-01 
Användarvisningsbild

Blev medlem: 18.59 2013-11-16
Inlägg: 1099
Ort: Stockholm
Ett alternativ är LM358. Den har två op i samma kapsel men samma kapseltyp som en singel. Dock lite annan pinkonfiguration

Den klarar enkel matningsspänning.


Upp
 Profil  
 
 Inläggsrubrik: Re: Ljud-minnebygge
InläggPostat: 22.00 2019-11-01 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.41 2012-12-13
Inlägg: 10854
Ort: Göteborg
Tack opampen men jag gillar LM324 på flera sätt och hade helst sett en singel sådan :)

Är inte så förtjust i duals, har inte en enda sådan, kör då hellre quads.

Har för mig att jag fick tipset nån gång på en singel-ekvivalent men har glömt bort det.

Inte säkert det var på EF.

MVH/Roger
PS
LM324 driver ganska mycket ström (minst +/-10mA), den har Vcm ända ner till GND, den har minimum utgångsspänning mindre än 20mV och klarar 5V (eller lägre) som matning, samtidigt har den ett SR på 0,5V/us (1Vp@20kHz kräver bara 0,1V/us) och en GBW på 1,2MHz (dvs 20kHz vid en förstärkning på 60), allt detta medans den bara drar 1mA. Alla OP går att köra på enkel matningsspänning men detta gäller bara AC, vill man köra DC och nära rail så "krävs" LM324 eller liknande.


Upp
 Profil  
 
 Inläggsrubrik: Re: Ljud-minnebygge
InläggPostat: 22.11 2019-11-02 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.41 2012-12-13
Inlägg: 10854
Ort: Göteborg
Jag har nu caddat om min KLM en aning, inför alltså LM324 som 30dB-förstärkare till nedre LED-stapeln samtidigt som båda kretsarna har 1V som referensspänning vilket gör att den nedre kretsen inte behöver hantera lika låga spänningar som förut.

Hoppas komma undan offset-problemen på detta sättet samtidigt som det är denna variant databladet rekommenderar.

MVH/Roger


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
 Inläggsrubrik: Re: Ljud-minnebygge
InläggPostat: 23.59 2019-11-06 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.41 2012-12-13
Inlägg: 10854
Ort: Göteborg
Ikväll har jag monterat virsockeln, viretiketten, en 100nF över matningen för LM324 och 4 motstånd (10k, 390k//1M5, 10k) så att jag har gain unter kontroll (309k/10k+1) samtidigt som jag bestämt mig för att lasta ner utgången lite (10k) för att på så sätt hålla nere Vo(min) till närmare 20mV (enligt datablad), första LED har sedan en tröskelspänning på 31,6mV så om "offset" håller sig under 20mV är allt grönt.

Tyvärr verkar det som om jag behöver två motstånd till i komponentadaptern som nu är full, jag behöver detta för att LED1 och LED11 har en tendens att glöda när dom inte är aktiva vilket kan åtgärdas av 5k6 från pinne 1 till matning men detta har jag alltså inte plats för fast jag tror jag kommer löda motstånden direkt på kapseln istället.

MVH/Roger


Upp
 Profil  
 
 Inläggsrubrik: Re: Ljud-minnebygge
InläggPostat: 22.26 2019-11-18 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.41 2012-12-13
Inlägg: 10854
Ort: Göteborg
Mitt ljud-minne fungerar nu.

Innan jag provade min senaste modifikation så felsökte jag som jag alltid gör innan spänningssättning och såg efter ett tag att ett ben hos IC5 var ovirat, sen mätte jag kortslutning över de stora feedbackmotstånden och upptäckte att jag hade virat till fel ben.

När detta blev åtgärdat fungerade plötsligt grejerna.

Det behöver dock trimmas lite för dels så slocknar LED1&11 aldrig riktigt samtidigt som det finns ett trick för det (5k6 mellan pinne 1 och matning) dels så är det tänkt att denna apparat skall visa absolut ljudtryck rätt, det är alltså ingen relativ manick vilket hade varit enkelt att konstruera.

Med andra ord är skalningen känslig, just nu kör jag 1Vp som högsta nivå MEN jag lägger omslagspunkten på 0,71V för det är 1V-3dB men jag vet inte om detta är riktigt.

Systemet kan ju hantera allt upp till matning typ så ur den synvinkeln är väl 0,71V inte kritisk men om jag lägger omslagspunkten på 1V ja då kommer LED20 lysa för 1V eller mer, LED19 kommer då lysa för 0,71V eller mer (fast slockna vid 1V).

Kanske det jag ska ha utan att tänka för mycket :)

Bifogar video.

https://youtu.be/YfgtmgERuUU

MVH/Roger
PS
Personligen tycker jag det är kul att jag till slut lyckades fixa detta men när jag fick syn på mina felaktiga virningar och den eventuella härvan var jag dock på väg att ge upp :) De lägre 10 LED:en hanterar mycket låga nivåer, LED10 hanterar till exempel 31,6mV och LED1 1mV fast detta är faktiskt inte riktigt sant ty mitt senaste trick är att istället hantera 316mV respektive 10mV SAMTIDIGT som det som mäts i realiteten är 1mV till 31,6mV, det är bara ett trick för att slippa hantera så små signaler som jag alltså försökte med men drabbades av nån slags offsetproblematik.


Upp
 Profil  
 
 Inläggsrubrik: Re: Ljud-minnebygge
InläggPostat: 23.54 2019-11-29 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.41 2012-12-13
Inlägg: 10854
Ort: Göteborg
Idag flyttade jag i LED-kortet i KLM och kopplade in det.

Sen slog jag på spänningen och jag får en kul puls på c.a 20mVp (~58dBp).

Jag är ganska nöjd med bygget förutom att utgångsresistansen hos den emitterföljande sluttrissan tycks vara 1k5 nånstans.

Teoretiskt skall den dock vara runt 50 Ohm.

Så vad fan, rent utsagt, är det som händer?

Jag fattar inte.

Se det såhär, att om man inte belastar med 10k så får jag en viss spänning, när jag belastar med 10k så sjunker utsignalen med minst 10% och om emitterföljaren vore riktig skulle jag inte ens kunna se denna sänkning.

Så jag har nåt lurt fel här som innebär att jag måste kalibrera KLM utan last för att ens nå upp i rätt nivå, sen måste belastningen av sinus-utgången vara hög, säg 100k eller mer, när den används.

Fast jag ser inte det här som nåt problem annat än aningen irriterande.

Mitt nästa steg blir att bygga en liten trehalva-adapter för inkoppling av kareoke-mikrofon till KLM, jag vill börja med det mest för skoj skull.

Därefter måste jag köpa ett XLR-kablage för 185 spänn på Gitarren här i stan, sen kommer jag nyttja den 300Hz-ton jag spelade in från min hemmabyggda skivspelare (KSP) och har i iTunes-biblioteket, samtidigt som jag kommer mäta med min Fluke23 DVM över högtalaringången så att jag har 1,0W i 4 Ohm, vartefter jag placerar mikrofonen 1m ifrån högtalaren och ska då få 91dBp ljudtryck från Faital Pro som jag kan kalibrera min KLM efter.

MVH/Roger


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
 Inläggsrubrik: Re: Ljud-minnebygge
InläggPostat: 19.55 2019-12-06 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.41 2012-12-13
Inlägg: 10854
Ort: Göteborg
Test med Kareoke-mikrofon misslyckades.

Eventuellt bifogar jag en video på detta.

Mitt bygge är alltså ingen VU-meter utan en peak-detektor, det är skillnad.

Tidskonstanten för följande av signalen har jag precis uppmätt till runt 20ms och detta trots 100nF//470k=50ms MEN jag tror det beror på läckande Ge-diod som jag lite lekfullt satte i serie med detektorn (100nF//470k).

Detta får till följd att visst insignalen följs men ripplet blir ganska stort på låga frekvenser och jag vill egentligen bara indikera peak MEN LED får ju inte hänga kvar där hur länge som helst.

Testade precis med 2kHz och då funkar det perfekt, dock vill jag kunna mäta ända ner till 20Hz vilket gör att tidskonstanten då måste vara 100 ggr längre än den jag har idag.

100*50ms=5s (efter 15s kan vi då betrakta kondingen som urladdad) så i detta fallet blir systemet väldigt långsamt samtidigt som peak kommer fångas och fladder i mätningen kommer inte existera, det kommer bli en enskild "dot" som rör sig enligt peak.

När man sedan mäter med KLM så får man helt enkelt svepa väldigt långsamt med tongeneratorn om man vill mäta högtalare, 15s kommer inte behövas ty signalen dippar inte så mycket på en gång MEN 1s per frekvens bör man nog vänta.

R4 är idag kortsluten så jag har tänkt klippa upp den (för jag har redan monterat kortet och det är knöligt att löda underifrån) och införa en switchdiod (1N4148) istället som definitivt läcker mindre.

Jag borde alltså ha runt 50ms men har runt 20ms och det lär bero på läckage hos Ge-dioden som jag dock slängde dit för att slippa R4, en annan anledning kan dock vara att jag nyttjar BJT med en visserligen liten basström som laddar ur C3.

Mitt nästa steg blir att införa switchdioden och mäta eventuell skillnad hos T, mest för att det är intressant faktiskt samtidigt som det är föga troligt att Ge-dioden håller så mycket högre läckageresistans än det 470k (R2) som sitter där.

Därefter är tanken att om inte 100-faldiga så i alla fall 50-faldiga T där jag dock kommer börja med att klippa loss R4, om det inte hjälper måste jag skruva loss och lyfta ur kortet för att byta konding vilket jag innerligt hoppas att jag slipper.

https://youtu.be/8wXfsoTA5fM

MVH/Roger


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
 Inläggsrubrik: Re: Ljud-minnebygge
InläggPostat: 20.05 2019-12-07 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.41 2012-12-13
Inlägg: 10854
Ort: Göteborg
Ta mig tusan om jag inte råkat skapa det perfekta ljudminnet!

Efter lite modifieringar funkar nämligen konstruktionen helt perfekt!

Först adderade jag en 1N4148 i serie med Ge-dioden och mätte varvid tidskonstanten typ fördubblades fast jag tyckte inte det räckte, sen klippte jag bleadern (R2) som ju ihop med kondingen sätter tidskonstanten.

DÅ hände det saker.

För det första fick jag klockrena sågtandssignaler som rippel istället för urladdningskurvor, detta tror jag beror på att emitterföljaren behöver en viss liten KONSTANT basström som den suger ut ur kondensatorn, för det andra blev tisdskonstanten (som i det här fallet faktiskt inte är definierad) att minska med ökande frekvens, rätt käckt.

Vid 20Hz har jag runt 20ms i tidskonstant men den är som sagt inte riktigt definierad fast orsak till rippel är ju periodtiden i vilket fall.

Ärligt talat fattar jag inte varför det blev såhär bra men KLM är klockren nu!

Skriker man in i mikrofonen med låg frekvens (och relativt låg nivå, obs) så finns inget LED-rippel, samma gäller om man skriker med hög frekvens, allt jag har är en vandrande LED (vars "attack" dock begränsas av Ge-dioden) som var precis det jag ville ha.

En annan justering jag gjorde var att jag blev så konfunderad över själva mikrofonförstärkarens emitterföljare ty den klippte negativt samtidigt som jag tyckte mig ha koll på belastningsimpedans och därmed negativt sving (-Ieq*RL) så jag "uppgraderade" emitterströmmen en faktor 10 och vips blev det också att fungera :)

Nu kan jag alltså med råge skicka ut 1Vp till LED-tillsatsen som är kalibrerad för 1V max.

Ibland har man tur :)

https://youtu.be/GH4Kae56rY4

MVH/Roger
PS
Bifogar eventuellt en video om jag orkar lägga upp den på tuben.


Upp
 Profil  
 
 Inläggsrubrik: Re: Ljud-minnebygge
InläggPostat: 21.38 2019-12-09 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.41 2012-12-13
Inlägg: 10854
Ort: Göteborg
Bifogar det moddade och fungerande schemat på den ingående mikrofonförstärkaren (KMA_D).

TTL-delens komponenter är inte monterade.

Lite kul uträkning, först urladdandes kondensator:

U=U_0e^{-t/RC}

dvs

U_0-U=\Delta U=U_0(1-e^{-t/RC})

detta gäller vanlig RC-urladdning (dvs EJ konstant ström) men för konstant ström gäller

\Delta U=\frac{I}{C}\Delta t

där vi önskar jämföra vad som händer vid t=T=RC dvs

\Delta U=U_0(1-e^{-1})=\frac{I}{C}\Delta t

vilket ger

\Delta t=0,63U_0*\frac{C}{I}

RC-nätet har alltså laddat ur sig till 37% när vi jämför T och dt.

I mitt fall får jag alltså som mest 1Vp/DC in på peakdetektorn och med den biaserade emitterföljaren och 10k som emittermotstånd får jag då en KONSTANT basström på runt 100uA som alltså laddar ur kondensatorn (100nF).

För lägre peakspänningar blir basströmmen motsvarande mindre och det är bara att sätta in i den sista ekvationen så får man en längre dt.

Detta gör så att ripplet blir störst för höga spänningar men minst för små spänningar så pga ren tur har jag fått ett system som reglerar in sig själv :)

Detta gäller inte bara nivå utan även frekvens för vad som händer vid lägre frekvenser är ju att det blir längre tid för kondensatorn att ladda ur sig MEN lutningen på den urladdningen är samma som för alla frekvenser OCH dessutom inte lika "brant" som för RC-nät.

Så på nåt underligt sätt verkar jag lyckats knåpa ihop nåt "topnotch" :)

MVH/Roger


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Svara på tråd  [ 55 inlägg ]  Gå till sida Föregående  1, 2, 3, 4

Alla tidsangivelser är UTC + 1 timme


Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 1 gäst


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
   
Drivs av phpBB® Forum Software © phpBB Group
Swedish translation by Peetra & phpBB Sweden © 2006-2010