Electrokit Buggfix Plus
Aktuellt datum och tid: 11.58 2020-02-28

Alla tidsangivelser är UTC + 1 timme




Svara på tråd  [ 29 inlägg ]  Gå till sida 1, 2  Nästa
Författare Meddelande
InläggPostat: 22.25 2019-08-17 
Användarvisningsbild

Blev medlem: 22.56 2008-11-27
Inlägg: 3405
Ort: Utanför Jönköping
Hejhopp!

Grannen kom med en stendöd 27" Asus-skärm. Han hade slagit på den och då hade säkringen i huset gått(?) (Kan ha varit jordfelsbrytare, har frågat grannen men inte fått svar än).

Efter det var den stendöd.

Jag skruvade isär den och konstaterade att själva skärmen/LCD:n har en metallbaksida. bakom denna metallbaksida sitter både styrkort och nätdel. Nätdelens kretskort har sin lödsida mot skärmens metallbaksida.

Nätdelen sitter skruvad i tre hörn och ska vara instucken i en skåra i det fjärde hörnet. Detta hörn var av så den satt inte i skåran.
(Gissar att det var ett fabrikationsfel eller möjligen något som hänt under resans gång, kretskortshörnet fanns inte i lådan, men kan kanske ha gått att skaka ur och det är därför det saknas?

I vilket fall så är min hypotes att nätdelskortet har kunna flexa lite. Därför har ett av de längsta komponentbenen kommit emot skärmens metallbaksida (som jag tror är jordad). En stackars ytmonterad konding och en lödpunkt har blivit väldigt varm som kan ses på bilderna nedan.

När jag backtrace:ar känns det ändå som att kortslutningen inte bör ha drabbat några viktiga komponenter, här behöver jag er hjälp. Självklart kan vad som helst ha hänt, men platsen är ändå relativt "nära" 230V växelspänning, tror det är nån form av likriktad 230V.

Lödde bort en likriktarbrygga och den mäter bra från bägge AC-benen till plus. 0.5V spänningsfall på diodmätning och ingen kontakt på andra hållet, men mellan AC och minus är det kortis på alla håll. Samt kortis mellan de bägge AC-benen. En säkring på 230V-sidan 2A snabb tror jag är också trasig.

Kretsen där ett av benen kortslöt är en sexbening typ TO220: STR W6262A. Visuellt så har den inte brunnit iaf. Den troliga Pinnen går att spåra direkt tillbaka till minus på likriktarbryggan. Fast vid närmare eftertanke kanske den tog benet bredvid vilket skulle förklara att den lilla SMD-kondingen är ledsen. Säkrast att ersätta denna också gissar jag och hoppas att inget annat dog...

Danny?

MVH: Mikael


Logga in för att visa de filer som bifogats till detta inlägg.


Senast redigerad av adent 15.26 2019-12-28, redigerad totalt 1 gång.

Upp
 Profil  
 
InläggPostat: 17.33 2019-08-20 
Användarvisningsbild

Blev medlem: 15.30 2007-05-17
Inlägg: 1865
Ort: Skåne
Hej

Har PM'at dig :)


Upp
 Profil  
 
InläggPostat: 20.48 2019-08-24 

Blev medlem: 16.55 2017-05-17
Inlägg: 147
Ort: Oslo, Norge
Hmm. Var det ikke noe isolasjon mellom kretskortet og metallbaksiden?
Kanskje lurt med en bit Kapton tape på det aktuelle området før du skrur i hop skjermen.


Upp
 Profil  
 
InläggPostat: 16.45 2019-08-31 
Användarvisningsbild

Blev medlem: 22.56 2008-11-27
Inlägg: 3405
Ort: Utanför Jönköping
Köpte likriktare, 6-benig switch-IC, säkring och SMD-kondingen som exploderat av Danny.
Bytte allt nu och skärmen startar hur fint som helst.

tingo: Det var oisolerat ja, märkligt nog så satt en isolermatta ovanför komponenterna, men ingen under.
Å andra sidan så är konstruktionen sådan att lödsidan omöjligtvis kan nå metallen om inte kretskortets hörn hade varit av...
Körde med kaptontejp och en liten trasselsudd med kapton för att hålla upp kortet.


Senast redigerad av adent 22.30 2019-08-31, redigerad totalt 1 gång.

Upp
 Profil  
 
InläggPostat: 16.48 2019-08-31 
Användarvisningsbild

Blev medlem: 21.16 2009-02-22
Inlägg: 18543
Ort: Säter
Kul att det gick att reparera. :tumupp:


Upp
 Profil  
 
InläggPostat: 17.17 2019-08-31 
Användarvisningsbild

Blev medlem: 15.30 2007-05-17
Inlägg: 1865
Ort: Skåne
Gott att du fick det att fungera med de komponenter jag skickade :) :tumupp:

Bild


Upp
 Profil  
 
InläggPostat: 10.46 2019-09-09 
Användarvisningsbild

Blev medlem: 22.56 2008-11-27
Inlägg: 3405
Ort: Utanför Jönköping
Inte för att det hör hemma i den här tråden, men nu kom samme granne med en Sony-förstärkare som blinkar "Protector". Har googlat lite och
det verkar ganska vanligt. Actual fel kan nog skilja lite. Som tur är verkar detta vara en något äldre modell där moderkortet sitter på en separat platta som går att skruva loss utan att plocka isär förstärkaren i molekyler. Servicevänligt! Högst troligt är det väl nån av effekttransistorerna som gett sig.

Ska titta på det när jag hinner. Tror det var en Sony STR DE875.


Upp
 Profil  
 
InläggPostat: 20.35 2019-09-09 
Användarvisningsbild

Blev medlem: 15.30 2007-05-17
Inlägg: 1865
Ort: Skåne
Fler projekt :tumupp: :)


Upp
 Profil  
 
InläggPostat: 15.25 2019-12-28 
Användarvisningsbild

Blev medlem: 22.56 2008-11-27
Inlägg: 3405
Ort: Utanför Jönköping
Åkej Danny!

Jag har pillat isär förstärkaren och mätt på komponenterna. Den har 5 likadana uppsättningar med tre trissor, Antagligen typ PNP, NPN och en lite mindre som jag inte vet vad den är till för.

En av, vad jag gissar är huvudkanalerna, mäter kortis på de stora trissorna.

Har diod-mätt lite alla möjliga kombinationer och de kombinationer som ger ett stabilt värde (antagligen Bas->Emitter) stannar på typ 0.64V. Förutom en av kanalerna där det är 0V på både PNP och NPN. (Det är bra med flerkanaliga förstärkare, många referenser att mäta på :) )

Den lilla trissan i mitten verkar ok. Det vita 2W två-i-ett-motståndet mäter rätt på ena sidan och oändligt på andra (Ska vara 0.22 Ohm).

Bilden visar inte den kanal som mäter fel för den sitter förstås sämst till att komma åt.

MN2488 och MP1620. Den lilla i mitten D2012. Samt det vita motståndet med sina tre tacksamma felsökningsben uppåt.

MVH: Mikael


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 16.29 2019-12-28 

Blev medlem: 19.03 2015-11-28
Inlägg: 258
adent skrev:
...förstärkare som blinkar "Protector"...

Jag hade samma fel på en stärkare jag "lagade" för något år sedan. Blixten hade gått i den, och den gick i Protect-läge. På den modellen fick man hålla inne ett par knappar på fronten, och då låstes protect-läget upp. Behöver ju inte vara samma för dig, men tänkte det kanske var intressant.


Upp
 Profil  
 
InläggPostat: 16.50 2019-12-28 
Användarvisningsbild

Blev medlem: 15.30 2007-05-17
Inlägg: 1865
Ort: Skåne
Tyvärr har jag inte de trissorna.
Inte ens ersättare.
Det är darlington trissor.

Här är lite tips på ersättare om original inte går att få tag i:

"I ordered MN2488-OPY-M and MP1620-OPY-M transistors from Sony and got 2SD2488 and 2SB1620 as substitutes."

https://alltransistors.com/transistor.p ... stor=61752

2SB1647 and 2SD2560


Upp
 Profil  
 
InläggPostat: 18.19 2019-12-28 

Blev medlem: 16.00 2014-10-08
Inlägg: 2204
Ort: Sörmland: 59.395514, 16.465287
Här kan man tydligen få hela 5 par för under 200;
Kan vara värt att satsa. Förmodligen kopior, även om dom påstår annat

https://se.grandado.com/products/5-par- ... transistor


Upp
 Profil  
 
InläggPostat: 14.25 2019-12-29 
Användarvisningsbild

Blev medlem: 22.56 2008-11-27
Inlägg: 3405
Ort: Utanför Jönköping
Beställde transistorer från holland på ebay och motstånd från Lettland på ebay. Hoppas det funkar och att inget annat pajjat!


Upp
 Profil  
 
InläggPostat: 20.19 2020-01-09 
Användarvisningsbild

Blev medlem: 22.56 2008-11-27
Inlägg: 3405
Ort: Utanför Jönköping
Motstånd och trissor har anlänt. Har plockat ur de gamla.

Tror ni jag kommer undan med att byta dem och tuta och köra?

Ett trebenigt 2x 22mOhm-motstånd avbrott på ena sidan. Både PNP och NPN verkar inte riktigt friska som jag redan konstaterat.
Bör jag undersöka något mer?

MVH: Mikael


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 01.07 2020-01-10 

Blev medlem: 16.00 2014-10-08
Inlägg: 2204
Ort: Sörmland: 59.395514, 16.465287
Små drivtransistorerna bör du kolla. Är det fel på dom då kan effekttrissorna ryka igen
ganska snabbt.


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Svara på tråd  [ 29 inlägg ]  Gå till sida 1, 2  Nästa

Alla tidsangivelser är UTC + 1 timme


Vilka är online

Användare som besöker denna kategori: Biker, GFEF, Majestic-12 [Bot], valmetman och 8 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
   
Drivs av phpBB® Forum Software © phpBB Group
Swedish translation by Peetra & phpBB Sweden © 2006-2010