HJÄLP! Mach 4 och setup.

Robot, CNC, Pneumatik, Hydraulik, mm
Användarvisningsbild
frallzor
Inlägg: 1207
Blev medlem: 6 mars 2007, 18:19:47
Ort: Hörby

Re: HJÄLP! Mach 4 och setup.

Inlägg av frallzor »

Tänkte börja om helt, lyckades ställa om så att limits = borta nu


Men vid enable, så låser motorerna och håller emot, så här långt allt ok.
Men de vill inte jogga alls, vad kan vara fel? Iom att jag har ett hållmoment så bör ju motorerna vara rättkopplade, men kan jag ha vänt på step dir etc? Har lyckats få minimal rörelse, men inget mer, åt ett håll.

Motordrivarna =2HSS57-A-5/24 styrkort PoKeys57CNC 1.4

Kopplat Enable, step, dir etc, det man förväntar sig, även dragit alarm, men iom att där inte är något alarm vad jag kan se så ska det inte spela roll i detta fallet.

Vad kan jag ha missat? Ska kika om jag ställt om dipparna till microsteg rätt sen när jag har tillgång igen, risken är att de är på helt annat värde än vad jag räknat ut till mach4.

Iom rätt dum kabeldragning och montering av kontakter i lådan så är det rätt svårt att komma åt så funderar på att helt enkelt fräsa
ut en fin platta där man kan montera allt lite enklare, underlätta felsökning och tydliga markeringar på varje kontakt.
Användarvisningsbild
frallzor
Inlägg: 1207
Blev medlem: 6 mars 2007, 18:19:47
Ort: Hörby

Re: HJÄLP! Mach 4 och setup.

Inlägg av frallzor »

Lite mer liv i allt, misstänkte att det kaaaanske kunde vara att motorerna inte orkade flytta axlarna men de är väldigt lättflyttade för hand, och fick till slut liv i Z när jag kopplade in allt. Den om någon är extremt lättflyttad men ljudet från motorn kanske säger vad som kan vara fel?

Skriv svar