Buggfix Plus
Aktuellt datum och tid: 10.23 2019-09-19

Alla tidsangivelser är UTC + 1 timme




Svara på tråd  [ 7 inlägg ] 
Författare Meddelande
InläggPostat: 20.29 2018-03-06 
EF Sponsor
Användarvisningsbild

Blev medlem: 16.26 2004-12-31
Inlägg: 7265
Ort: Trelleborg
Hej EF!

Nu är det dags att ta tag i gamla projekt som ligger och skräpar i arbetsrummet, har ett påbörjat förförstärkarprojekt och ett datorhögtalarprojekt.
Dessa ska kombineras till ett, från förförstärkarprojektet tar jag ett USB-ljudkort, SPDIF till I2S-omvandlare och en röd 2x24 LCD, från datorhögtalarprojektet tar jag två förstärkarkort baserade på en KlassD-stärkare på 2x25W (TIs TAS5713) samt högtalare som består av en subwoofer (har glömt elementet, dubbla talspolar har det iaf) samt två bredbandare (Peerless P830985).

Tanken är att få till följande kedja USB -> PCM2704 (Ljudkort) -> ADUM110N (Magnetisk signalisolator) -> CS8416 (Digitalljudsreceiver) -> TAS5713 (Förstärkare) -> Högtalare.
Sidanom sitter en MSP430 som pratar med LCD och förstärkarchippen, förstärkarchippen har nämligen DSP-funktionalitet, så jag tänker använda dessa som delningsfilter.

Status just nu:
- USB-ljudkortet behöver jag byta chippet på.
- Signalisolatorn borde funka
- Digitalljudsreceivern funkade när jag labbade med den senast.
- Förstärkarchippen har jag fått att funka i ett tidigare system, men håller på att bestycka ett annat kort.
- MCUn har jag fått att läsa av en rotationsencoder och skriva ut till display.
- Högtalarna är färdiga och väntar på input.

Bilaga:
IMG_20180305_194457.jpg

Bilaga:
IMG_20180305_194421.jpg


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 21.06 2018-03-08 
EF Sponsor
Användarvisningsbild

Blev medlem: 16.26 2004-12-31
Inlägg: 7265
Ort: Trelleborg
Tydligen hade mitt ljudkort inte alls gett upp, utan det var bara jag som var oförmögen till att koppla in det rätt.

Har även knackat någon rad till på MCU-koden.


Upp
 Profil  
 
InläggPostat: 21.22 2018-03-08 

Blev medlem: 09.06 2016-12-01
Inlägg: 758
Ort: Marks Kommun
Vilken MCU har du?


Upp
 Profil  
 
InläggPostat: 07.25 2018-03-09 
EF Sponsor
Användarvisningsbild

Blev medlem: 16.26 2004-12-31
Inlägg: 7265
Ort: Trelleborg
Jag kör på TIs Launchpad för MSP430, så det är väl MSP430G2553 om jag inte missminner mig.


Upp
 Profil  
 
InläggPostat: 09.58 2018-03-15 
EF Sponsor
Användarvisningsbild

Blev medlem: 16.26 2004-12-31
Inlägg: 7265
Ort: Trelleborg
Igår lödde jag klart förstärkarkorten:
Bilaga:
IMG_20180314_135349.jpg


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 18.09 2018-03-15 
Användarvisningsbild

Blev medlem: 19.22 2008-12-17
Inlägg: 4192
Ort: Kävlinge
Jag vill titta, tar du med till jobbet i morgon?


Upp
 Profil  
 
InläggPostat: 09.48 2018-03-16 
EF Sponsor
Användarvisningsbild

Blev medlem: 16.26 2004-12-31
Inlägg: 7265
Ort: Trelleborg
Crap, var på AW igår och gick rätt i säng när jag kom hem.

Så tyvärr ligger de hemma :(


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Svara på tråd  [ 7 inlägg ] 

Alla tidsangivelser är UTC + 1 timme


Vilka är online

Användare som besöker denna kategori: Anahka1975 och 12 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
   
Drivs av phpBB® Forum Software © phpBB Group
Swedish translation by Peetra & phpBB Sweden © 2006-2010