Buggfix Plus
Aktuellt datum och tid: 09.42 2019-12-16

Alla tidsangivelser är UTC + 1 timme




Svara på tråd  [ 50 inlägg ]  Gå till sida 1, 2, 3, 4  Nästa
Författare Meddelande
InläggPostat: 00.03 2019-07-25 
EF Sponsor
Användarvisningsbild

Blev medlem: 22.54 2006-09-23
Inlägg: 32629
Ort: Borås
Hustruns PUG fick spel i dag.
ett 20-tal felkoder.
Felkoderna handlar om diverse spridare, ventiler, bränslepump osv
De flesta indikerar "Kortslutning" typ, eller tja?

Efter en hel kvälls idogt bingande, så verkar det som att felet antingen är ett jordfel någonstans, eller ett fel på ett relä, naturligtvis inlött på ett kretskort.
Får fortsätta i morgon, uppenbarligen.

Felkoderna, ett urval:

BSMen ger F98A, F98B, F98C samt F99C
De tre första är lite lampor, men den sista är "Fel på bränslepumpens aktivering"

Motorstyrningen MM6LP ger 13 koder
P0105 är nog MAP givaren som jag bytte i dag
P0445 Evaporative Emission System Purge Control Valve Circuit Shorted
P0261 Injector 1 – circuit low
P0264 Injector 2 – circuit low
P0267 Injector 3 – circuit low
P0270 Injector 4 – circuit low
P0076 Intake Valve Control Solenoid Circuit Low Bank 1
P0135 O2 Sensor Heater Circuit Bank 1 Sensor 1
P0141 O2 Sensor Heater Circuit Bank 1 Sensor 2
P0351 Ignition coil A, primary/secondary – circuit malfunction
P0353 Ignition coil C, primary/secondary – circuit malfunction
P0354 Ignition coil D, primary/secondary – circuit malfunction
P0352 Ignition coil B, primary/secondary – circuit malfunction

Några av datorerna säger att det är CAN-fel, dvs U1208 och U1108


Upp
 Profil  
 
InläggPostat: 00.11 2019-07-25 
Co Admin
Användarvisningsbild

Blev medlem: 16.04 2006-04-16
Inlägg: 10487
Dom felkoder du radar upp tyder på fel i BSM.
Mät utgående spänningar där så dom stämmer.
Har hänt att dessa blivit skadade av vatten, råttpiss och annat.

Programmering behövs inte för utbyte, du kan bara plugga in en ny eller begagnad från skroten.
Finns billiga på ebay.


Upp
 Profil  
 
InläggPostat: 00.13 2019-07-25 
EF Sponsor
Användarvisningsbild

Blev medlem: 22.54 2006-09-23
Inlägg: 32629
Ort: Borås
Jo, jag har förstått det.


Upp
 Profil  
 
InläggPostat: 00.18 2019-07-25 
Användarvisningsbild

Blev medlem: 12.01 2006-02-24
Inlägg: 23031
Ort: Norr om Sthlm
har du kollat batterispänningen ? ..Låg batterispänning kan ge dom konstigaste problemen.. jag har exempelvis felsökt ABS/ESP-problem som visade sej bero på en kortsluten cell (eller kanske två) i batteriet så att spänningen var för låg..

Kanske inte är så troligt, men en bra sak att börja med att utesluta.


Upp
 Profil  
 
InläggPostat: 00.26 2019-07-25 
EF Sponsor
Användarvisningsbild

Blev medlem: 22.54 2006-09-23
Inlägg: 32629
Ort: Borås
Det verkar Ok, 14 V när motorn går, strax över 12 när den står stilla. Men naturligtvis, skall göra en belastningstest i morgon, men har för mig att det skall vara relativt nytt, och friskt, peppar peppar, dock.
Skall även kolla över jordningen, från batteriet mm.
Frenzy, hur mycket har du jobbat med PSA osv.
Man kan tydligen köpa ett token, för 300:- typ, ladda ned programvara och köra felsökning, omprogrammering osv online, dock hittar jag ingen information var man i så fall laddar ner programvaran (gissar att det är Servicebox man avser), har du en aning om detta?


Upp
 Profil  
 
InläggPostat: 07.52 2019-07-25 
Co Admin
Användarvisningsbild

Blev medlem: 16.04 2006-04-16
Inlägg: 10487
Som på alla bilmärken kan man enligt lag i EU betala en månadsavgift eller dagsavgift för att få tillgång till original diagnosprogramvara, ofta krävs det dock att man registrerar sig som företag och kan behöva gå igenom vissa steg för att bli godkänd.

Om vi börjar med den information du har så kan man ringa in en felkod i taget. Om vi tar till exempel denna:
P0261 Injector 1 – circuit low

Tyder på att det antingen saknas spänningsmatning till spridarna eller att det är kortslutning på en kabel.

Det jag skulle göra först är att ta fram ett elschema, kolla om ECM styr mot mot jord eller spänning och kolla vilket stift spänningen ska komma på. Sen jobbar man bakåt därifrån.

Vad har du för regnr på bilen?


Upp
 Profil  
 
InläggPostat: 09.00 2019-07-25 
EF Sponsor
Användarvisningsbild

Blev medlem: 22.54 2006-09-23
Inlägg: 32629
Ort: Borås
WDU 455


Upp
 Profil  
 
InläggPostat: 09.28 2019-07-25 
Co Admin
Användarvisningsbild

Blev medlem: 16.04 2006-04-16
Inlägg: 10487
Både spridare och tändning får spänning från säkring F10 genom relä 2 i BSM.
Lyft på locket och mät om den säkringen har spänning när tändningen är påslagen.
Har den inte spänning så får du kolla säkring F1.

Om säkring F1 är hel och det finns spänning på utgång B5 så fungerar relä 1.
Då är antingen relä 2 trasigt eller saknar styrspänning från BSM.

Om svaret är nej så har du fel på BSM eller det som styr denna.

Skickar schemat via mail.


Upp
 Profil  
 
InläggPostat: 09.39 2019-07-25 

Blev medlem: 05.46 2018-07-30
Inlägg: 115
En intermittent kortslutning som skapar kaos pga spänningsdippar kan också vara orsaken. En av felkoderna kan därmed vara relevant för felkällan, t.ex nåt ställdon/spjällmotor etc.


Upp
 Profil  
 
InläggPostat: 10.28 2019-07-25 
Co Admin
Användarvisningsbild

Blev medlem: 16.04 2006-04-16
Inlägg: 10487
Jag gjorde ett urklipp ur schemat och ritade lite:

ECM (motorstyrenheten) jordar blå ledning vilket får relä 1 att slå till.
Om säkring F1 är hel kommer då spänning till relä 2.

BSM jordar grön ledning vilket får relä 2 att slå till.

Om säkring F10 är hel kommer nu spänning ut på kontakt B4 till spridare och B2 till tändspole

Bilaga:
Skärmklipp 2019-07-25 11.18.34.png


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 11.43 2019-07-25 
EF Sponsor
Användarvisningsbild

Blev medlem: 22.54 2006-09-23
Inlägg: 32629
Ort: Borås
Det verkar vara väldigt sporadiskt, och olika fel varje gång.
I dag när jag körde ut den till garaget, stendog den.
kopplade upp Diagbox, Den kunde inte hitta motorstyrningen utan signalerade "okänd dator".
Senatre, efter 10 minuter startade den, och inga felkoder lagrade.
Btw, hur vet man om man har en "Äldre BSI" eller en "Crossrange BSI"


Upp
 Profil  
 
InläggPostat: 12.07 2019-07-25 
Co Admin
Användarvisningsbild

Blev medlem: 16.04 2006-04-16
Inlägg: 10487
Eftersom den nu påstår att det är kortslutning i EVAP skulle du kunna koppla ur den för felsökning. Koppla även ur annat "onödigt" som drivs av F10 tex lambdasonderna och värmen till spjällhuset.

Sen får du kanske försöka logga signalerna 1203, 1229 och 1150 från BSM

Felsökningsmetod 1
Utan att logga kan man prova att tjuvkoppla 12V till B5. Fungerar det nu så är felet i relä 1 eller signal 1229.
Blev det ingen skillnad så prova tjuvkoppla 12V till F10, fungerar det nu så är felet i relä 2 eller signalen från BSM.

Felsökningsmetod 2
Koppla in en batteriladdare
Koppla en halogenlampa på F1 och en på F10
Slå på tändningen och vänta och se ifall en eller båda lampor slocknar

Felsökningsmetod 3
Anslut med diagbox till BSM (genom BSI)
Gör en graf med loggning på alla ut och insignaler
Vänta tills motorn dör och kolla vad som försvann först

Vet inte hur det är med Peugeot men på service.citroen.com kan man se reservdelslistan gratis, skriver man in sitt VIN och evt ORGA-nr så ser man exakt vilka delar som är monterade på bilen.


Upp
 Profil  
 
InläggPostat: 12.17 2019-07-25 
Användarvisningsbild

Blev medlem: 20.19 2009-11-24
Inlägg: 2282
Ort: Ljungby
Jag var med om att tätningen i kontakten till motorstyrningen tätade lite dåligt på min Peugeot Expert (2005) och att stiften därmed oxiderade. Massa lustiga och sporadiska felkoder tills bilen inte startade alls.
Jordfel/dålig jordning brukar också orsaka inkonsekventa problem i canbus-system.


Upp
 Profil  
 
InläggPostat: 14.32 2019-07-25 
Användarvisningsbild

Blev medlem: 04.51 2005-11-23
Inlägg: 3177
TomasL skrev:
Det verkar Ok, 14 V när motorn går, strax över 12 när den står stilla. Men naturligtvis, skall göra en belastningstest i morgon, men har för mig att det skall vara relativt nytt, och friskt, peppar peppar, dock.
Skall även kolla över jordningen, från batteriet mm.
Frenzy, hur mycket har du jobbat med PSA osv.
Man kan tydligen köpa ett token, för 300:- typ, ladda ned programvara och köra felsökning, omprogrammering osv online, dock hittar jag ingen information var man i så fall laddar ner programvaran (gissar att det är Servicebox man avser), har du en aning om detta?


Blybatterikemier har 12.8 vid fulladdat - vissa ännu högre men vi säger svag belastning minst 12.7V
Strax över 12 är alldeles för lågt - 12.5 är acceptabelt om man är på väg till batteributiken.

Detta med motorn avstängd naturligtvis


Upp
 Profil  
 
InläggPostat: 15.01 2019-07-25 
EF Sponsor
Användarvisningsbild

Blev medlem: 22.54 2006-09-23
Inlägg: 32629
Ort: Borås
12,8 med svag belastning, dvs tändning påslagen.


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Svara på tråd  [ 50 inlägg ]  Gå till sida 1, 2, 3, 4  Nästa

Alla tidsangivelser är UTC + 1 timme


Vilka är online

Användare som besöker denna kategori: 4kTRB, arvidb, l2t, Wedge och 20 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
   
Drivs av phpBB® Forum Software © phpBB Group
Swedish translation by Peetra & phpBB Sweden © 2006-2010