Buggfix Plus
Aktuellt datum och tid: 07.08 2019-12-16

Alla tidsangivelser är UTC + 1 timme




Svara på tråd  [ 512 inlägg ]  Gå till sida Föregående  1 ... 30, 31, 32, 33, 34, 35  Nästa
Författare Meddelande
InläggPostat: 16.16 2019-07-09 
Användarvisningsbild

Blev medlem: 17.06 2017-04-15
Inlägg: 929
Ort: Malmö
Den senaste versionen av rtl_433 har IKEA Sparsnäs som device, nr 130.
Jag testkörde lite igår, men fick inga vettiga paket att dekoda, kan bero på att min RTL-dongel sitter en bra bit från sändaren.


Upp
 Profil  
 
InläggPostat: 18.09 2019-07-09 
Användarvisningsbild

Blev medlem: 10.05 2004-06-08
Inlägg: 1090
Ort: Vinninga/Lidköping
Testa med typ 1024k sample rate och ev högre gain. Kör med debugflaggan så ser du om alla bytes är med.


Upp
 Profil  
 
InläggPostat: 18.50 2019-07-15 

Blev medlem: 18.29 2016-03-05
Inlägg: 51
oj det var en hel del sidor.. som jag behöver bläddra mig igenom.

Köpte en ikea sparsnäs på blocket.
Tanken är att försöka med betoning på försöka få in det in Home assistent, sett några skriva om det. Behöver lära mig bara vad allt är. kör rpi 3 med hassio så hoppas det går att lösa. För att se min elförbrukning i realtid.


Upp
 Profil  
 
InläggPostat: 21.04 2019-07-24 

Blev medlem: 18.29 2016-03-05
Inlägg: 51
hur ska man fylla i senor id i HA?

är det "SENSORS": "400736174"
"SENSORS": "400736 174"
"SENSORS": "40073 6174"

osv


Upp
 Profil  
 
InläggPostat: 17.05 2019-07-30 

Blev medlem: 18.29 2016-03-05
Inlägg: 51
är den här ut döende:/ ? verkar inte vara många som använder den,


Upp
 Profil  
 
InläggPostat: 17.38 2019-07-30 
Användarvisningsbild

Blev medlem: 17.06 2017-04-15
Inlägg: 929
Ort: Malmö
Jag har inte kopplat över min till SDR än, men jag misstänker att du ska mata in siffrorna utan mellanslag i strängen.
Eller så skriver du inget ovh programvara bruteforcar koden.
Kolla källkoden på github så ser du hur det funkar.


Upp
 Profil  
 
InläggPostat: 17.20 2019-07-31 

Blev medlem: 18.29 2016-03-05
Inlägg: 51
ne.. tror det blir att sälja den.. mqtt verkar inte var vara min grej.. Fattar verklige inte har läst, diskuterat med folk men än då lyckas jag inte få till de. Så bättre att någon annan som har bättre kunskap än mig få ta över den. Vet inte om felet ligger på sj hassio mqtt broker eller om det är sj ikea sändaren..


Upp
 Profil  
 
InläggPostat: 19.53 2019-07-31 

Blev medlem: 17.59 2009-12-21
Inlägg: 3565
Vad försöker du göra egentligen ?

Har du byggt en mottagare själv ?
Vilken kod använder du ?


Upp
 Profil  
 
InläggPostat: 18.30 2019-08-03 

Blev medlem: 18.29 2016-03-05
Inlägg: 51
nej

kör hassio med home assistent och ikea add on, , kör med den här sändaren:https://www.lohelectronics.se/kommunikation/amatorradio/radio/rtl-sdr-r820t2-rtl2832u-1ppm-tcxo-sma-sdr.

tror jag har fått ordningen på mqtt, men när jag söker så får jag bara upp: Could not find the sensor please verify that the sensor id is: 400736174

det här är min confi på ikea hassio add on
{
"SENSORS": "400736174 1000",
"MQTT_HOST": "192.168.1.66",
"MQTT_PORT": 1883,
"MQTT_USERNAME": "mqtt",
"MQTT_PASSWORD": "1234"
}

Det kankse bara är jag, men tycker att read me filen är ganska så rörig men tror jag är med på noterna


EDIT: kan förtydliga min post.
man sak ta bort 400 i id för att det ska funka


Senast redigerad av berne 10.59 2019-08-05, redigerad totalt 1 gång.

Upp
 Profil  
 
InläggPostat: 16.17 2019-08-04 

Blev medlem: 18.29 2016-03-05
Inlägg: 51
yay.. nu har jag i alla fall fått mqtt att funka,
men det står i redame att man ska ange det här för att se,

i expemelt står det: mosquitto_sub -v -h 192.168.x.x -u username -P password -t '#'
SÅ jag antar att det ska skrivas så här:
mosquitto_sub -v -h 192.168.1.66 -u berne -P 123456789 -t '#'

men får inte något på det komandot, å fort samma svar från ikea addon:
Could not find the sensor please verify that the sensor id is: 400736174


Upp
 Profil  
 
InläggPostat: 01.06 2019-08-05 

Blev medlem: 16.55 2017-05-17
Inlägg: 137
Ort: Oslo, Norge
Hmm, dersom hass.io bruker den innebygde mqtt serveren til Home Asssitant, så kan det hende at du må gjøre slik:
Kod: [Expandera/Minimera] [Hämta] (Untitled.txt)
mosquitto_sub -V mqttv311 -h bpi -u user -P password -t

parametret -V angir versjon på mqtt-protokoll.

Jeg har selvlaget Home Assistant oppsett, og bruker klienten slik
Kod: [Expandera/Minimera] [Hämta] (Untitled.txt)
mosquitto_sub -V mqttv311 -h bpi -u homeassistant -P password -t home/rtl_433

jeg kjører også rtl_433 på en annen Pi enn der Home Assistant kjører, så jeg bruker dette for å publisere fra rtl_433 til mqtt serveren
Kod: [Expandera/Minimera] [Hämta] (Untitled.txt)
rtl_433 -R 19 -F json -U | mosquitto_pub -V mqttv311 -h bpi -u homeassistant -P password -t home/rtl_433 -l

Som du ser har jeg valgt et annet "topic" (-t).


Upp
 Profil  
 
InläggPostat: 10.58 2019-08-05 

Blev medlem: 18.29 2016-03-05
Inlägg: 51
Löst det till slut nu funkar den som den ska, har hittat senor å allt. Nu försöker jag bara få in det i HA.
har gjort Packages av filen som det står i guiden.https://github.com/tubalainen/sparsnas_decoder/tree/master/home-assistant
har lagt till följande i config:
sensor:
- platform: mqtt
state_topic: "sparsnas/736174"

men får ändå massa felkoder som det här:
Invalid config for [sensor.mqtt]: [hidden] is an invalid option for [sensor.mqtt]. Check: sensor.mqtt->hidden. (See ?, line ?). Please check the docs at https://home-assistant.io/components/sensor.mqtt/

tror det är 6st.
Kan inte se var problemt ligger,
state_topic bör ju vara sparsnas/736174 det är som står först i tex terminal när den skicka singnalerna.


Upp
 Profil  
 
InläggPostat: 22.20 2019-08-11 

Blev medlem: 16.55 2017-05-17
Inlägg: 137
Ort: Oslo, Norge
Tja, filen sparsnas_mqtt.yaml inneholder flere linjer av type
Kod: [Expandera/Minimera] [Hämta] (Untitled.txt)
 hidden: true

i seksjoner med "platform: mqtt", kan det være slik at sesor mqtt ikke støtter denne opsjonen?


Upp
 Profil  
 
InläggPostat: 09.07 2019-08-12 
Användarvisningsbild

Blev medlem: 12.01 2006-02-24
Inlägg: 23028
Ort: Norr om Sthlm
Kan notera att min sparsnäs slutade logga häromveckan, efter att jag tagit mej fram i djungeln ut till mätarskåpet på stolpen så konstaterade jag att det som hade hänt var att sensorn lossnat från mätaren, detta hade hänt för att original "skumtejp" hade disintegrerat.

Jag tejpade fast den med maskeringstejp då jag råkade ha det på mej.


Nu loggar den igen :)


Upp
 Profil  
 
InläggPostat: 11.50 2019-09-07 

Blev medlem: 19.03 2015-11-28
Inlägg: 241
Jag byggde min mottagare för Sparsnäs (https://elektronikforumet.com/forum/viewtopic.php?p=1357610#p1357610) för ca 2 år sedan, och nu i dagarna varnade mitt system för övervakning av batteri att jag behöver byta batteri. Nästan 2 år, är nöjd med det.


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Svara på tråd  [ 512 inlägg ]  Gå till sida Föregående  1 ... 30, 31, 32, 33, 34, 35  Nästa

Alla tidsangivelser är UTC + 1 timme


Vilka är online

Användare som besöker denna kategori: metric och 16 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
   
Drivs av phpBB® Forum Software © phpBB Group
Swedish translation by Peetra & phpBB Sweden © 2006-2010