Buggfix Plus
Aktuellt datum och tid: 17.24 2018-04-25

Alla tidsangivelser är UTC + 1 timme




Svara på tråd  [ 17 inlägg ]  Gå till sida 1, 2  Nästa
Författare Meddelande
InläggPostat: 11.40 2018-03-14 

Blev medlem: 18.58 2010-08-29
Inlägg: 19
Bilen växlar inte, driven går inte i och enligt mercedes så är det växelspakshistorian, den kostade minst 3000:- och hade nån veckas leveranstid, så jag åkte dit och hämtade kretskortet för att ta ett span och se om det gick att göra nåt. Här är bilder på eländet. Finns 7st små kretsar med tre ben som heter A22L och 6st visade samma ohm värde och en va udda, nån som vet vart man kan finna info om denna kretsen eller hur man ska mäta den på "riktigt"? Tyvärr är nedre kortet limmat och smält fast så man kan bara mäta en del saker, har även kollat med lupp efter konstiga lödningar. Nån som har tips på nån bra sida där man kan se och jämföra kretsar och lära sig vad det är?


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 11.48 2018-03-14 

Blev medlem: 18.58 2010-08-29
Inlägg: 19
Kan det va nån typ av hall sensor? eftersom den sitter i en krökning som följer spaken, så det känner av i vilket läge spaken är?


Upp
 Profil  
 
InläggPostat: 12.25 2018-03-14 
EF Sponsor
Användarvisningsbild

Blev medlem: 16.26 2004-12-31
Inlägg: 7257
Ort: Trelleborg
Den ser förvisso ut att vara inkopplad annorlunda, skulle gissa på att det är därför den mäter annorlunda också.


Upp
 Profil  
 
InläggPostat: 13.10 2018-03-14 

Blev medlem: 18.58 2010-08-29
Inlägg: 19
Så tänkte jag också, men på mellersta bilden, på det andra kortet uppe till vänster sitter 2st kretsar av samma modell och de är heller inte inkopplade lika och mäter samma, och då funderar man varför sitter det två stycken hallgivare där? Fick ju aldrig med spaken så jag vet inte hur den ser ut, kan ju va till manuella växlingen på lådan (+ och - om man drar spaken i sidled)


Upp
 Profil  
 
InläggPostat: 13.14 2018-03-14 
EF Sponsor
Användarvisningsbild

Blev medlem: 16.26 2004-12-31
Inlägg: 7257
Ort: Trelleborg
De yttre benen ser nämligen sammankopplade ut genom ett motstånd, detta kan säkert ge andra mätvärden.


Upp
 Profil  
 
InläggPostat: 13.20 2018-03-14 
Användarvisningsbild

Blev medlem: 13.58 2016-04-05
Inlägg: 1271
Ort: Helsingfors
Det så kallade A i "A22L" ser litet egendomligt stiliserat ut.


Upp
 Profil  
 
InläggPostat: 13.32 2018-03-14 

Blev medlem: 18.58 2010-08-29
Inlägg: 19
Tror det kommer från "Allegro microsystems" och de gör tydligen hall sensorer https://www.allegromicro.com/en/Design-Center/Technical-Documents/Hall-Effect-Sensor-IC-Publications/Allegro-Hall-Effect-Sensor-ICs.aspx


Upp
 Profil  
 
InläggPostat: 13.37 2018-03-14 
Användarvisningsbild

Blev medlem: 16.35 2010-03-12
Inlägg: 1145
Ort: Smedjebacken
A är förmodligen Allegros logo, och de tillverkar bland annat halleffektsensorer.

EDIT: Ibland är man för långsam :)


Senast redigerad av ajje 13.40 2018-03-14, redigerad totalt 1 gång.

Upp
 Profil  
 
InläggPostat: 13.38 2018-03-14 
Användarvisningsbild

Blev medlem: 13.58 2016-04-05
Inlägg: 1271
Ort: Helsingfors
Verkar troligt, likadant A där.


Upp
 Profil  
 
InläggPostat: 13.53 2018-03-14 

Blev medlem: 14.59 2006-02-27
Inlägg: 3869
Ort: Tranås (Jönköping)
Skulle väl inte misstänka hall-givarna direkt, speciellt inte med tanke på moderkortet som sitter under.
Det finns ju nån typ av uC där, så det pratar väl CAN mot bilen. Får du svar av verkstaden om de har felkod på att nåt är tokigt med modulen, eller om den inte svarar alls?
Det kan ju vara så "enkelt" som nåt i kablaget eller spänningsregleringen i modulen.

Första budordet i felsökning:
- One should always check thy power rails -

Alltså, försök hitta pinout till modulen, spänningsmata den och mät om alla spänningar finns.


Upp
 Profil  
 
InläggPostat: 14.06 2018-03-14 
Användarvisningsbild

Blev medlem: 13.58 2016-04-05
Inlägg: 1271
Ort: Helsingfors
Litet vilda spekulationer.

Ja, att själva komponenten skulle bli trasig känns inte så sannolikt, ...eller kanske om den får i sig en rejäl statisk urladdning? Men vad tycker lödningarna om vintertida stora och snabba temperaturförändringar. Et krökt kort kanske ger litet extra utmaningar. Antar att det varit plant vid ytmonteringen och krökts sen.


Upp
 Profil  
 
InläggPostat: 14.13 2018-03-14 
Användarvisningsbild

Blev medlem: 14.52 2005-01-10
Inlägg: 22689
Ort: Kristinehamn
Det känns mycket säkert att det är magnetsensorer i någon form.

Men att alla har lagt av samtidig känns främmande, alltså kvarstår något gemensamt. Så råden med att kolla att det finns ström osv. är helt riktiga.

Jag skulle tro att sensorerna är av typen Honeywell SS549AT som generisk typ.


Upp
 Profil  
 
InläggPostat: 14.26 2018-03-14 
Användarvisningsbild

Blev medlem: 13.58 2016-04-05
Inlägg: 1271
Ort: Helsingfors
Synvilla, eller är dethär litet off?
Bilaga:
paasidan.jpg


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 15.08 2018-03-14 

Blev medlem: 18.58 2010-08-29
Inlägg: 19
Tackar för alla svar, ska fortsätta ikväll när barnen lagt sig. Den registrerar att parken är i, men inte R och D. Tyvärr så är det inga felkoder, men de hade haft några stycken mercor som hade samma fel och då va det denna "modulen" som lagt av. Jävligt kasst av en märkesverkstad att behöva gissa sig fram vad som är felet, de borde ju kunna prova boxarna i en dator så alla funktioner fungerar. Va ju lite därför jag släpade dit den. Har ju gjort en del andra jobb på bilen innan jag drog dit den som att byta connectorplaten i lådan, lite kontakter på lådan, kollat bromsljus switchen, bytt olja. Själva databoxen till lådan va full i olja pga läckande kontakt på lådan så det blev kapillärverkan, den är rengjord samt att de testade med en box de hade på verkstaden. Efter era svar så känns det inte troligt att det är sensorerna iaf.


Fått låna en modul av en kompis så ska dit imorgon och byta den och hoppas på bot och bättring. Ska man mäta det nedersta kortet så måste man kapa bort lite plast och lim, trist och laga sönder den om det inte är det som är felet :)


Upp
 Profil  
 
InläggPostat: 16.30 2018-03-14 

Blev medlem: 14.59 2006-02-27
Inlägg: 3869
Ort: Tranås (Jönköping)
Får ni ut en del växellägen men inte alla eller bara ett läge?
Jag spånar bara nu:

- En del lägen, typ P och nån mer, då skulle jag tro på sensorkortet.

- Bara P, kanske sensorkortet, men kanske säger systemet P som en failsafe för att det inte får kontakt med modulen trots allt.

Jag röstar fortfarande på att spänningssätta modulen och mäta.
En datablad på hall-givarna så du kan mäta om de känner av lägena kan ju vara en idé.


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Svara på tråd  [ 17 inlägg ]  Gå till sida 1, 2  Nästa

Alla tidsangivelser är UTC + 1 timme


Vilka är online

Användare som besöker denna kategori: AndersG, Chaf, konig7070, larsolsson och 28 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
    Agstu.se
Drivs av phpBB® Forum Software © phpBB Group
Swedish translation by Peetra & phpBB Sweden © 2006-2010